Xero - error handling and pay run processing troubleshooting

 This guide contains the following topics:

  • Invalid ordinary earnings rate ID
  • Superannuation Guarantee Contribution line missing in Xero pay template
  • Additional hours added into the Xero pay run
  • Tracking categories are not assigned to roles
  • There can only be one draft pay run per calendar
  • Payroll calendar may not be changed while the employee has unprocessed leave
  • Error exporting user Payroll Calendar may not be changed while an unprocessed timesheet exists for this employee
  • Could not refresh authorisation.  Please ensure Xero is configured correctly.

 

Invalid OrdinaryEarningsRateID

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REQUIRED: Ensure the pay item 'Ordinary Hours' is active in Xero

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RECOMMENDED: Ensure the pay item is set as the 'Ordinary Earnings Rate' in the employee's Employment section 

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Superannuation Guarantee Contribution line missing in Xero pay template

Cause of the error:

Xero requires a Superannuation Guarantee Contribution line in the employees pay template if they are 18 years or over.

Resolution:

  • Follow the Xero guide here to add the Superannuation Guarantee Contribution line to the employee(s) pay template.
  • Follow the easyemployer guide located here to re-export the pay run

 

Additional hours added into the Xero pay run

Check the Xero pay template to ensure the hours are removed.  For example, Xero will automatically add 76 hours into the pay run for this employee. 

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Tracking categories missing from roles

REQUIRED:

  • when using tracking categories in Xero, all roles in easyemployer are required to have cost centres, even if they are not used within that payroll. 
  • Cost centres in easyemployer have to match Xero tracking categories 

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There can only be one draft pay run per calendar

Example of the error

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This error is being reported by Xero, it is not an easyemployer error.

If this error is received, it means there is a draft pay run already in Xero.  The draft pay run must be processed or removed before exporting from easyemployer to Xero. 

 

Payroll calendar may not be changed while the employee has unprocessed leave

This error is being reported by Xero, it is not an easyemployer error.

If this error is received, it means there are unprocessed leave requests for the affected user(s) in Xero.  

 

Error exporting user Payroll Calendar may not be changed while an unprocessed timesheet exists for this employee

This error is being reported by Xero, it is not an easyemployer error.

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If this error is received, it means there are unprocessed timesheets for the affected user(s) in Xero.    These timesheets need to be removed before exporting the payroll report again.

 

Could not refresh authorisation.  Please ensure Xero is configured correctly.

Example of the error

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Cause of the error

Xero is rejecting the connection which happens after the API connection to easyemployer has been unauthorised in Xero

Process to fix

To fix the issue the connection between easyemployer and Xero needs to be re-authorised

Guide here

  1. In easyemployer, open the organisation structure
  2. Click the payroll entity that is connected to Xero
  3. Click settings 
  4. Under Xero click disconnect
  5. Click connect under Xero and follow the prompts to authorise the connection
  6. Repeat for other payroll entities that have lost the connection to Xero. 
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