easyemployer web application system requirements and supported browsers

easyemployer is a web-based application that runs in a web browser.

Before you use easyemployer, make sure your computer meets or exceeds the minimum hardware requirements for your operating system (Windows or macOS) and you are running a supported operating system version.  See Microsoft or Apple's website for the requirements and supported operating system versions. 

easyemployer is tested with the following web browsers running in Windows or macOS X. Your browser must be a stable release version; not an alpha, beta, nightly, or development build. This applies to all browsers, regardless of the operating system:

easyemployer web application:

Google Chrome: latest version - recommended browser
Mozilla Firefox: latest version
Apple Safari: latest version
Microsoft Edge: latest version

Browser configuration:

JavaScript must be enabled
Cookies must be enabled
Local storage must be enabled
TLS v1.2 or above

If you are currently using Internet Explorer 11, we recommend you switch to Microsoft Edge or another supported browser.

Microsoft recently announced plans to make Edge broadly available across more versions of Windows beyond Windows 10. 

To check if your browser is up to date click here

For additional information regarding how to update an internet browser click here.

The following are links to download these free browsers:

Google Chrome

Mozilla Firefox

Safari (Apple Mac Only)

Have more questions? Submit a request

Comments

Powered by Zendesk