Xero | Error Handling + Pay Run Troubleshooting

1) Error handling

i) Invalid OrdinaryEarningsRateID
ii) Superannuation guarantee contribution line missing in xero pay template
iii) Additional hours added into the xero pay run
iv) Tracking categories missing from roles
v) There can only be one draft pay run per calendar
vi) Payroll calendar may not be changed while the employee has unprocessed leave
vii) Error exporting - user Payroll Calendar may not be changed while an unprocessed timesheet exists for this employee
viii) Could not refresh authorisation. Please ensure xero is configured correctly
ix) Please ensure Xero is configured and connected

 


🔍 RELATED ARTICLES

Xero | Integration Information
Xero | Initial Integration Setup + Application Sync


 

1) Error handling

Known errors and their resolutions are listed below (click on th error to expand).


i) Invalid OrdinaryEarningsRateID

EXAMPLE OF THE ERROR:

2019-11-18_14h12_54.png

i.i) Ensure 'Ordinary Hours' is active in xero

REQUIRED: Ensure the pay item 'Ordinary Hours' is active in xero.

NOTE: If you have more than one pay item called 'Ordinary Hours' and there is one in the inactive list, please make this active.

2019-09-11_09h10_45.png

i.ii) User import

Perform a user import for the user that is shown in the error

  1. In Easy Employer, click 'organisation'.
  2. Click 'import/export'.
  3. Click 'import/update users'.
  4. Select the users payroll entity and click next.
  5. Click 'Toggle All' under display toggles.
  6. Click 'Skip All'.
  7. Find the user that is is showing in the error.
  8. "Unskip" the user.
  9. Import the user.

i.iii) Ordinary Earnings Rate' in the employee's file in xero

NOTE: Ensure the pay item is set as the 'Ordinary Earnings Rate' in the employee's Employment section.

2019-09-11_09h11_33.png

ii) Superannuation guarantee contribution line missing in xero pay template

CAUSE OF THE ERROR:

Xero requires a Superannuation Guarantee Contribution line in the employees pay template if they are 18 years or over.

SOLUTION TO THE ERROR:

  1. Follow the Xero guide HERE to add the Superannuation Guarantee Contribution line to the employee(s) pay template.
  2. Follow the Easy Employer guide "Xero | Exporting a Payrun + Re-Exporting a Payrun" to re-export the pay run.
iii) Additional hours added into the xero pay run

CAUSE OF THE ERROR:

The xero pay template likely has default values set.

SOLUTION TO THE ERROR: 

Check the xero pay template to ensure the hours are removed.  For example, xero will automatically add 76 hours into the pay run for this employee. 

2019-09-11_09h13_59.png

iv) Tracking categories missing from roles

CAUSE OF THE ERROR:

  1. When using tracking categories in xero, all roles in Easy Employer are required to have cost centres, even if they are not used within that payroll.
  2. Cost centres in Easy Employer have to match xero tracking categories.

2019-11-04_11h27_10.png

SOLUTION TO THE ERROR:

1. Refer to the Easy Employer guide "Xero | Tracking Categories" for further details on this function.

v) There can only be one draft pay run per calendar

EXAMPLE OF THE ERROR:

mceclip0.png

SOLUTION TO THE ERROR:

This error is being reported by xero, it is not an Easy Employer error.

  1. If this error is received, it means there is a draft pay run already in xero. The draft pay run must be processed or removed before exporting from Easy Employer to xero. 
vi) Payroll calendar may not be changed while the employee has unprocessed leave

This error is being reported by Xero, it is not an Easy Employer error.

  1. If this error is received, it means there are unprocessed leave requests for the affected user(s) in xero. These unprocessed leave requests will need to be rejected in Xero.
vii) Error exporting - user Payroll Calendar may not be changed while an unprocessed timesheet exists for this employee

EXAMPLE OF THE ERROR:

2020-03-10_13h03_04.png

SOLUTION TO THE ERROR:

This error is being reported by xero, it is not an Easy Employer error.

  1. If this error is received, it means there are unprocessed timesheets for the affected user(s) in xero. These timesheets need to be removed before exporting the payroll report again.
viii) Could not refresh authorisation. Please ensure xero is configured correctly

EXAMPLE OF THE ERROR:

2020-04-20_11h23_09.png

CAUSE OF THE ERROR:

xero is rejecting the connection. This occurs when the API connection to Easy Employer has been unauthorised in xero.

SOLUTION TO THE ERROR:

  1. To fix the issue; the connection between Easy Employer and xero needs to be re-authorised.
  2. Follow the Easy Employer guide "Xero | Initial Integration Setup + Application Sync" to reconnect Easy Employer to your xero account.
ix) Please ensure Xero is configured and connected

EXAMPLE OF THE ERROR:

xero_error.png

SOLUTION TO THE ERROR:

  1. To fix the issue; the connection between Easy Employer and xero needs to be re-authorised.
  2. Follow the Easy Employer guide "Xero | Initial Integration Setup + Application Sync" to reconnect Easy Employer to your xero account.
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